Visit email notifications not received by visitors
2026-04-28Last updated
To resolve issues with missing visitor email notifications, designated approvers can verify and process pending visit or area access requests in Genetec ClearID™.
Cause
Visit email notifications aren’t received because the visit event or visit area request wasn’t approved.
Solution
To resolve this issue, the designated approvers must review and clear any pending requests
in the system that are blocking the email notification.
Depending on the type of request the visitor is
waiting for, see the following approval procedures: